
 
 

File Names  
   
In order to prevent any problems with your web site it is useful to follow these rules 
when naming your site files:  
   
1. Length – Your filenames should not exceed 8 letters in length  
2. Spaces – Do not have any spaces in your filenames  
3. Capitals – Do not use capital letters in your filenames  
4. Numbers – Do not use a number as the first character in your file names    
 
   
Site Creation Preparation  
   
1. Create your site folder  
2. Create your images sub-folder in the web site folder  
3. Create the images you will need and copy them into the images folder. 
 
 
Netscape Composer 
 
To run Netscape Composer  
Start – Programs – Netscape – Composer 
Or use the icon in the bottom left of the Navigator window.  
 
In Netscape Composer, the tabs in the bottom left of the screen are important. The 
two tabs you will be using are the Normal and the Preview tabs.  
   

  
 
   
Normal View – This is the standard page creation and edit view  
Preview – Selecting this tab will show you what your web page will look like as 
viewed through a web browser  
  
 Starting off 
 
To Create a New Page – Select File Menu>New>Composer Page  
To Save the Page - Select File Menu>Save as...NB Watch where you’re saving files 
To Close the Page - Select File Menu>Close.  
 
Page Colours and Background 
 
Once you have created your first blank page, you can begin constructing it. The first 
thing to do however is to set up the page properties such as:  
   

• Title in the Browser window - Page Title  
• Page background colour or image  
• Text and link colours  
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These features are found in the Format menu.  
   

  
 
   
Page Colours and Background  
   
This box allows you to set the background properties of the page. It can be a colour or 
an image. In this example we will set a background colour.  
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First select Use Custom Colours, and then click on the box next to the Background 
(by default this will be white). A grid of colours will appear. Select one, click on OK 
and your page should change colour.  
  

 

 
 
   
Background Image  
   
You can use an image as a background to the page. There are implications for doing 
this:  
   

• Will the image take more time to download?  
• Will the background image obscure the text or content?  

 
   
Test this feature by opening the Page Colours and Background box and selecting 
Browse. Locate the site folder you have been given and enter the background 
subfolder. Select one of the files there and see the effect on your web page. 
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Page Title  
 
 
 
Each web page needs a title. 
This appears in the very top left 
of the browser window and 
helps to brand the site and give 
some basic information to the 
user. 
  
 
   
There is also the ability to enter a description of what the site contains. This will not 
appear to anyone visiting the site but will appear in Search Engines. The description is 
a useful tool in assisting in people searching for and selecting your site.  
 
   
In the Format menu, select Page Title and Properties.  

 
   
This box is straightforward. Just fill in the information, as it is relevant to you. Make 
the Page Title fairly descriptive, for example more than just one word. 
 
Saving and Previewing Web Pages 
 
It is important to view your web page, as it will appear in a browser regularly 
throughout the design process. Netscape Composer makes this process easy. If you 
look at the bottom left hand corner of the screen you will see a row of tabs:  
  

 
  
Normal: This is your basic design view and is used when you are editing or creating 
web pages.  
Show All Tags: This view shows your content with small mark to show the html 
formatting commands  
Source: This view shows the html code that your page is described by  
Preview: This shows your web page as it should appear in a web browser  
  
   
In essence, you work in Normal view, regularly checking the Preview view to see 
how your site will actually appear.  
   
Text Formatting 
 
Text in Netscape Composer is handled almost the same as it would be in a word 
processing package. For example you type directly onto the page and then select the 
text (highlight it) and then format it. You can change:  
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• Font (Use a sans-serif font such as Arial, Comic sans or Verdana) 
• Alignment  
• Size  
• Style   

   
Or change the way it is presented i.e.  
   

• Bold, Italics  
• Numbered or bulleted list (like this one)  

  
To demonstrate how easy this is, type text onto a page. Select it, by clicking and 
dragging your mouse over the text while holding the button down.  
   
You can then use the commands in the Format menu, or the toolbar as shown here: 
 
 
 
 
   
  

 
 
   

• Paragraph Format - HTML, the language of web pages, has 7 main styles pre-
programmed It is better to use headings as they will show up consistently in all 
browsers. They range from Heading 1 (large type) to Heading 7 (very small) 
and also include Body Text (standard text) and Paragraph.  

• Text Colour: Click to select an alternative colour for the selected text.  
• Text Size: Select to increase or decrease the size of the text.  
• Bold, Italic, and Underline: As in standard word processors. Be careful about 

using the underling function as this is normally reserved for the link action and 
can confuse users of your site.  

• Lists: Use to create ordered (numbered) or Unordered (bulleted) lists.  
• Indent, Outdent: Use to position text – not recommended.  
• Alignment: Use to centre, right or left align, or justify text.  

 
Inserting Images 
 
Images are an important aspect of a web site. They can engage and inform a visitor to 
your web site but there are a few considerations to think about. These are dealt with at 
the bottom of this page, but first let's see how Netscape Composer places images.  
   
First steps  
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• Prepare your image and have it located in the correct folder.  
• Position the cursor at the point you wish the image to be placed in.  
• Using the Insert menu, select Image, or select the Image icon from the toolbar.  

 
Locate the image using the Choose File button. N.B. The image must be in the same 
overall folder as the web page  
   
You should then fill in the Alternative Text for those who use Screen Readers to surf 
the World Wide Web. Then select OK.  
   
Once the image is on the page you can format it by selecting the image (clicking on it 
once) and then use the alignment buttons on the toolbar to select left, right, or centre 
alignment.  
   
Double clicking on the image will open up the Dialog box again and you can select a 
different file or edit the Alternative Text.  
   
Alt Text  
This is the text that will be displayed when the mouse is hovering over it and is very 
useful for partially sighted users who use screen readers so please always add Alt Text 
to your images.  
   
Guidelines for Images  
Images are large files compared to text and may take a while to display (much to the 
annoyance of the user). You should also have the image the correct size before you 
link it to the page. There are techniques for resizing the way an image is displayed but 
they are not always reliable.  
 
Linking Pages 
 
Links are key to the World Wide Web. They allow for the user to move (navigate) 
through your site and onto other sites of interest.  
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A hyperlink can be a piece of text, or an image.  A hyperlink can move the user to:   
   
1. A point in the same document  
2. Another document  
3. A set point in another document  
  
   
Before you link two pages, you must have two pages to link. 
   
1. Select the text or image you wish to use as a link  
2. In the Link Properties box browse for the file you wish to link to by clicking on the 
Choose File button. Then locate the file you wish to link to and select it.  
3. Don't forget to link the linked page back to the original.   
   
If you are providing a link to a web page on another web site you have to enter the 
full web address into the Link Location box. For example to link text or an image to 
the Hibernia College site:  
   
1. Select the text or image you wish to use as a link  
2. In the Link Properties box enter the full address for the site you are linking to, i.e. 
http://www.hiberniacollege.net. Note that you must include the http:// at the start of 
the address.  
 
More about Links 
 
Links can do more than just move a user to a different web page. Named Anchors can 
move a user to a specific point in the same web page or a specific point in another 
web page.  
   
Named Anchors  
   
An anchor tag is a location in a web page. The anchor tag is invisible to the user but 
allows a designer to link to that specific point. 
To insert a named anchor - Firstly, place the cursor at the correct point in the 
document i.e. where you want the link to move to. Using the Insert menu, select 
Insert>Named Anchor. This will open the Named Anchor box as shown below.  
  

 
Once you have given your anchor a name, select OK. This will insert the anchor at the 
insertion point. In Composer this will appear on the page, but this tag will be invisible 
to the user.  
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Now that the anchor is established, you can link to that point using the Link Properties 
box in the normal way. The difference is the use of the # to distinguish the use of a 
named anchor.  
   
For example to link to a named anchor (called "bottom") within the same page as the 
text or link acting as the link you would select the element (text or image) to act as the 
link and insert #bottom in the link property box.   
   
To link to a named anchor in a different page, select the element to act as the link and 
link to the page as normal. i.e. the link might look like page_1.htm. To link to the 
named anchor "bottom" in that just add #bottom to the end of the link with no spaces. 
i.e. the link will now look like page_1.htm#bottom.  
   
A common application for this feature is a Top function. It is common for users of 
long web pages to want to return to the top of the page (where navigation is often 
restricted to). They can use the vertical scroll bar but a more considerate way would 
be to put in a named anchor. If you insert a named anchor called "Top" in the first line 
of the web page and then link this to a text link at the bottom of the page 
 
Tables 
 
Tables are very useful in web design as they allow you to place images and text on a 
page so that they are fixed in their position.   
   
To insert a table, use the insert menu and when you have selected tables, the 
following will appear:   
   

  
 
   
By using story boarding, you should know what type of table you will need though 
you can edit the number of rows and columns after the table is created.  
   
The width of a table can be set in either pixels (an absolute measure) or as a 
percentage of the browser window (relative). An absolute table will not resize if the 
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user resizes their browser window. A relative table (%) will shrink to display as a 
percentage of the available window size.   
   
Once you have created your table you can edit it in various ways. The Table 
Properties box is reached by selecting Table>Table Properties from the table menu.  
 
You must have your cursor in the table you wish to edit to access this box.  

  
 
   
Table Tab  

• Tables do not have to have a border and they are then invisible to the user.  
• Cell padding is the space between the content of the cell and the cell wall.  
• Cell spacing is the space between cells.  
• The table can be aligned to the left, centre, or right of the page.  
• A background colour can be applied to the table.  

  
   
Cell Tab  

• Many of the same attributes can be applied on the cell level.  
• A background colour can be applied to an individual cell.  

 
Tables for Layout 
 
Tables, especially invisible ones, are useful for creating a consistent look and feel 
across the pages in a web site.  
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Tables without borderlines are very useful for placing text and images correctly on the 
page. For example, using a two-column table with an image in the right-hand column 
and text in the left column.  
   
You can have a top row (a header) that contains a banner with headings as well as a 
row at the bottom (a footer) that contains contact information and copyright 
statements.  
   
Once you have created one page that has a structure that you are happy with, you can 
then copy that table across all of the pages in your web site.  
 
Putting it all together 
 
 
Over the last set of pages, you have leant how to add all of the major components of a 
web page. Putting it all together taking these pages and trouble shooting them, 
checking all of the little details that can take up so much time at the end of a project.  
   
Checklist  
   

• Do all of the navigation links within the site work?  
• Do all of the navigation links outside the site work?  
• Do all of the images have Alt Text?  
• Does each page have a title in its page properties?  
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